Get in touch
Back
Maintenance

Upgrade to Integrations on backend.

Completed 26 Oct at 05:42pm BST.

Members Portal Executive Portal Partner Portal Website SUSNA Events SUSNA Contact Partner Programme Login Pages
Completed

Maintenance completed

Posted 26 Oct at 05:42pm BST.
Started

Access to the website may be degraded during the maintenance period. We are currently upgrading the backend systems which may mean that your experience of the SUSNA website is slower.

Please bear with us whilst we work on these upgrades, and report to us via https://betteruptime.com/report/47dAM3NsXRkhgaFpJK859nda if you experience any unexpected crashes or errors

Posted 25 Oct at 05:42pm BST.